From Exalted - Unofficial Wiki
Jump to: navigation, search

Comments and Questions About the Old Content of This Page

If you have an exciting idea for some form of code or new text formatting rule that ought to be implemented for this wiki, then please head over to WikiChanges and suggest it there. Comments from the old version of this page can be found in the discussion of this page.

Okay, for some reason you can't use the "nowiki" tag to keep bullet points from displaying themselves. Anyone know why?
~ Shataina

It is HTML, not the Wiki, that is interpreting your escape sequence. You want to write "•". - willows
Oh. Okay. I thought that couldn't be it because the wiki doesn't auto-interpret "%23", but I guess that's different.
~ Shataina

Is there a way to indent the first line, as in a paragraph in a book?

You could probably use  s, but it's likely better to set up a stylesheet using text-indent. - willows

Is there a way to center a word or phrase?
- HandofOmega2

I don't know if it's the Wiki, but anchor tags don't seem to be working; both on Firefox and IE I just get a page saying "This page is redirecting you to X Page, do you want to do that?", and then doesn't go to the anchor. Am I screwing something up?

Anchors have never worked here. Just don't try. - Trithne
It's true that InterPageLinks don't work, but I think the (unsigned) poster was talking about a new feature of Firefox, that displays a "I'm redirecting you" page instead of just redirecting you. I gather the intent is to help stop phishing from fooling people. - Wordman
That is indeed what I was thinking of. That said, if anchors don't work, we should possibly remove the information on how to place anchors from the Miscellaneous Rules section. (And whoops on the unsigning. I blame tiredness). - FrivYeti
I'd rather we actually just change a single chartacter in the code and fix the &%#$ing bug, but that isn't up to me. - Wordman

Anchors used to work, Trithne, you whippersnapper.  ;) Indeed, I myself wrote the Anchors section after exhaustive experimentation back when I first went over these rules. I guess UseMod has been updated in the interim. That said, I took the time to look at it a little more. It appears that actually typing in an anchor will lead you to it: frex, if you manually enter into the URL bar, you'll go to the proper place. Linking to it from the wiki is the problem. I don't have time to figure that out right now, but I am sure that someone who bothered to do a little experimentation could.
~ Shataina

No. Linking from the wiki is actually not the problem. The problem is that the anchors include the # character in their name. This requires links like the one you mention above, with two # characters in a row. I've installed the latest version of UseModWiki to test this. It does not have this problem. It builds the anchor with out the extra #, allowing the correct link to work (e.g. Basically, the issue is that half of the system (the part that builds the anchors) thinks their should be an extra #, while the other half (the part that builds links to the anchors) does not. It's the first part that is broken, not the second. See InterPageLinks for more examples. - Wordman
I suppose it kinda depends on your definition of "problem", huh? ;) Obviously anchors have always been *technically* broken, it's just a question of whether there's a workaround. There used to be one that worked OK even if it was silly; it's in the rules, but now it doesn't. So we can complain because the system is broken, or we can look for a solution. I sort of enjoy playing with the markup in an effort to find ways to work around these sorts of issues, but you and Trithne etc. apparently don't. So. If you guys aren't going to look for a new way to link to anchors from the wiki -- notwithstanding the fact that it *should* work another way -- then might I suggest that you email Xyphoid? You could also post something to WikiChanges, the page that exists specifically to ask for changes to the wiki, though I don't know if he checks that anymore.
~ S.
I've sent at least two emails about this problem and another specifically indicating I would track down the exact line that needed changing and how to fix it, presuming Xyphoid could tell me what version of the software this board uses. All were met with silence. So, as my attempts to help actually solve the problem have gone nowhere, I'm left with nothing but futile bitching about how colossally and unnecessarily stupid it is. This simple feature could make this wiki so much more useful. - Wordman